Hosted desktop login issues

Incident Report for Rightworks Hosting

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2026 - 13:47 EDT

Investigating

We are currently investigating an issue where users who reset their password may be able to sign in to AppHub but are unable to access their hosted environment (RDP). Our team is actively working on a resolution and will provide updates as more information becomes available.
Posted Jul 22, 2026 - 11:35 EDT
This incident affects: QuickBooks Hosting (Hosted Desktop).