Microsoft reported that Azure services should now be functional and we're seeing success with AppHub availability.
Posted Oct 29, 2025 - 19:39 EDT
Monitoring
As Microsoft continues their recovery of affected Azure services, we are now seeing successful logins to our AppHub site. If you continue to experience issues accessing accounts.rightworks.com, please contact our support team.
This issue has been identified and is related to an issue with Azure. Our engineers are in communication with Microsoft, and more updates will be provided as they become available.
This issue has been identified and is related to an issue with Azure. Our engineers are in communication with Microsoft, and more updates will be provided as they become available.
Posted Oct 29, 2025 - 12:19 EDT
Identified
This issue has been identified and is related to an issue with Azure. Our engineers are in communication with Microsoft, and more updates will be provided as they become available.
Posted Oct 29, 2025 - 12:13 EDT
Update
We are continuing to investigate this issue.
Posted Oct 29, 2025 - 12:05 EDT
Investigating
We are currently investigating reports of slowness or inability to log in to the AppHub portal and Transaction Pro Online. We will update this status page with more information as soon as it becomes available.
Posted Oct 29, 2025 - 11:57 EDT
This incident affected: Managed Microsoft Office 365 (Email Flow, Authentication Services), Transaction Pro (Transaction Pro for QuickBooks Online), and QuickBooks Hosting (AppHub Portal).