QuickBooks Hosting Support Unavailable

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Sep 30, 2025 - 15:42 EDT

Monitoring

Our team is coming back online and is taking calls/chats. Please note that hold times will be longer than normal as we recover.
Posted Sep 30, 2025 - 12:24 EDT

Identified

Due to a local emergency impacting our area, our phone and chat support services are currently unavailable. We are actively working with local providers to restore connectivity as quickly and safely as possible.

We understand this may cause inconvenience and appreciate your patience during this time. If your issue is urgent, please check our helpdesk at helpdesk.rightworks.com for self-service options. We will post further updates here as the situation evolves.
Posted Sep 30, 2025 - 10:10 EDT
This incident affected: Customer Communication Channels (Phone System, Chat).