Unable to Login to QuickBooks Online

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 11:37 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 18, 2025 - 09:46 EST

Update

As a result of the QBO login issues, Transaction Pro Online users may experience the same inability to log in. While the issue remains with Intuit's infrastructure, Rightworks engineers have been engaged.
Posted Dec 18, 2025 - 08:57 EST

Investigating

We have received reports that some users are experiencing issues accessing QuickBooks Online. When they try to log in, they get a 403 error. This issue is external to any of the Rightworks infrastructure, and Intuit has acknowledged this issue via their status page. For further updates, please visit https://status.quickbooks.intuit.com/
Posted Dec 18, 2025 - 08:17 EST
This incident affected: QuickBooks Hosting (QuickBooks) and Transaction Pro (Transaction Pro for QuickBooks Online).