Cloud Protect - Delayed Ticket Response Times

Incident Report for Rightworks Hosting

Resolved

The Cloud Protect ticketing system functionality has been fully restored and the issue has been resolved.
Posted Jul 10, 2026 - 16:29 EDT

Monitoring

Our ticketing system functionality has been restored. We will work to respond to all submissions as quickly as possible. If you are in need of immediate assistance, please call our support number at 1(888)241-5417. Our team will continue to monitor and make adjustments when needed.
Posted Jul 10, 2026 - 14:51 EDT

Update

We are continuing to investigate this issue.
Posted Jul 10, 2026 - 13:28 EDT

Investigating

We are currently experiencing an issue with our internal ticketing system resulting in slower than normal response times. Our engineers are working on identifying root cause and we will provide updates here as soon as they become available.

If you are experiencing an issue that needs immediate assistance, please contact support via phone at 1(888)241-5417.
Posted Jul 10, 2026 - 13:25 EDT
This incident affected: Security Products (Cloud Protect).