Office 365 Degraded Performance

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 08:45 EST

Identified

We have identified an issue affecting users of Office 365. Those who are impacted will experience issues with the admin portal and email delivery.

Microsoft has acknowledged this issue, and we are referring users to their status page for further information/updates: https://status.cloud.microsoft/

This is external to any Rightworks infrastructure.
Posted Jan 22, 2026 - 15:41 EST
This incident affected: Managed Microsoft Office 365 (Email Flow).