System Performance & Connectivity

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 16:08 EDT

Identified

We are currently experiencing higher-than-normal contact volume related to performance & connectivity of the Rightworks Hosted Desktop. Our engineers have determined that it is related to a network issue external to the Rightworks environment.

Some users are reporting that switching to a new network or mobile hotspot works as a temporary workaround.

We will provide updates here as soon as they become available.
Posted Oct 07, 2025 - 13:13 EDT
This incident affected: QuickBooks Hosting (Hosted Desktop, QuickBooks).