QuickBooks 2023 Slowness

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 15:31 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2025 - 08:33 EDT

Update

We have identified this issue to be related to a recent update to QuickBooks 2023. Our engineers are continuing to collaborate with Intuit to resolve this issue.
Posted Jul 30, 2025 - 11:38 EDT

Update

We are continuing to work with Intuit on a fix for this issue.
Posted Jul 29, 2025 - 13:18 EDT

Identified

We are currently investigating an issue affecting QuickBooks 2023 (Pro/Premier, and Enterprise) where users may experience slowness when opening company files. Our engineering team is actively collaborating with Intuit to identify the root cause and implement a timely resolution.

If feasible, we recommend upgrading to QuickBooks 2024, where this issue does not occur. For detailed instructions, please refer to this article: https://helpdesk.rightworks.com/s/article/How-to-Upgrade-QuickBooks-Desktop-to-the-Most-Recent-Version.

We will continue to monitor the situation and provide updates on this page as new information becomes available.
Posted Jul 29, 2025 - 08:25 EDT