AppHub Portal

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 11:09 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2025 - 10:12 EDT

Investigating

We are currently investigating reports of users being unable to log in to the AppHub portal.  Users are seeing a certificate error when trying to access the site. This can be bypassed by clicking on Advanced>Go to Site. Once this is done, you should not see the error again.

We will update this status page with more information as soon as it becomes available.
Posted Oct 07, 2025 - 10:02 EDT
This incident affected: QuickBooks Hosting (AppHub Portal).