System Performance Issues - Identified

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Nov 22, 2023 - 09:31 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2023 - 09:09 EST

Identified

Our engineering team has identified the root cause and is currently working to remedy the issue. We appreciate your patience as we work to restore full service to affected customers.
Posted Nov 22, 2023 - 08:51 EST
This incident affected: Application Cloud (Hosted Desktop).