Transaction Pro Online credit card charges and checks import failure

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:59 EST

Identified

This issue has been identified and is due to an issue with Intuit's purchase creation via batch API.

Intuit's team is working on a fix for this. We will provide more updates as we have them.
Posted Nov 18, 2025 - 14:04 EST

Investigating

We are currently investigating an issue in Transaction Pro Online where certain import types are failing with an error message that begins with "System Failure Error..."

This appears to be impacting the following import types: credit card charges and checks. Other import types seem to be working normally.

Please check back here or subscribe to this status page for further updates.
Posted Nov 18, 2025 - 12:40 EST
This incident affected: Transaction Pro (Transaction Pro for QuickBooks Online).