Practice / Cloud Protect

Incident Report for Rightworks Hosting

Update

We are continuing to investigate this issue.
Posted Jun 11, 2026 - 12:18 EDT

Investigating

We’re currently aware of an issue that is impacting our Practice / Cloud Protect users. Customers can log into the portal, but when attempting to launch applications, they get stuck in an authentication loop. Our team is currently investigating, and updates will be posted here as they are made available.
Posted Jun 11, 2026 - 09:25 EDT
This incident affects: Security Products (Cloud Protect).