Cloud Protect System Issue - Investigating

Incident Report for Rightworks Hosting

Monitoring

Customers are now reporting success when attempting to log into the portal. Our team will continue to monitor and make adjustments when needed. Please contact support if you are experiencing issues or have any questions.
Posted Jul 02, 2026 - 11:59 EDT

Investigating

We are currently experiencing higher than normal contact volume related to some clients being unable to sign into the portal. Our engineers are working on identifying root cause and we will provide updates here as soon as they become available.
Posted Jul 02, 2026 - 10:09 EDT
This incident affects: Security Products (Cloud Protect).