Frozen QuickBooks when exporting to excel

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 15:57 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 10, 2025 - 12:19 EDT

Identified

We are experiencing higher-than-normal call volume related to QuickBooks freezing when exporting to Excel. Our engineers are working to resolve this issue. In the meantime, users can avoid it by opening Excel before initiating an export from QuickBooks.

If your QuickBooks is already frozen, please call our support team at 888-417-4448 x2 or chat with us at https://helpdesk.rightworks.com/s/onespace.

Updates will be posted here as we have them.
Posted Oct 10, 2025 - 11:31 EDT
This incident affected: QuickBooks Hosting (QuickBooks).