Unable to login to QuickBooks Online (QBO)

Incident Report for Rightworks Hosting

Update

Intuit has posted to its status page. Please visit https://status.quickbooks.intuit.com/ for further updates.
Posted Jul 08, 2026 - 09:23 EDT

Investigating

We are currently receiving reports of the inability to log in to QBO. Users get an error message that says, "There's an issue on our end. We're on it."

We have engaged Intuit on this as it appears to be outside of the Rightworks infrastructure. There is no known workaround at this time.

Updates will be posted here as they arrive.
Posted Jul 08, 2026 - 08:58 EDT
This incident affects: QuickBooks Hosting (QuickBooks).