Chat Support Service Interruption

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 12:34 EDT

Investigating

It has come to our attention that there is a service interruption with our chat support. We are in touch with the appropriate party and are working diligently to restore this functionality. We appreciate your patience and understanding in this matter.

In the meantime, since the chat is not available, please contact our support team directly at 888-417-4448, Option 2, for additional assistance.
Posted Oct 13, 2025 - 10:51 EDT
This incident affected: Customer Communication Channels (Chat).