Phone System Issues - Identified

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Dec 05, 2023 - 14:46 EST

Identified

The issue is only impacting our toll-free inbound numbers. You can use the following local number to reach support (603)-324-8080 while we work with our telco vendor to resolve the problem.
Posted Dec 05, 2023 - 13:33 EST

Investigating

We are currently experiencing an issue with our phone system, which is impacting our ability to answer incoming calls. As a result, we would advise that you contact us via chat or email. Chat support can be accessed by navigating https://helpdesk.rightworks.com/s/ and click the “chat” button” on the lower right of the page. Email support is also available by sending an email to support@rightworks.com.
Posted Dec 05, 2023 - 13:28 EST
This incident affected: Customer Communication Channels (Phone System).