NordLayer VPN Organization ID Issue

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Jan 02, 2026 - 13:15 EST

Monitoring

Due to a recent NordLayer VPN driver update, some users may be signed out and unable to log back in because the Organization ID is no longer auto-filled. The Organization ID can be found in the NordLayer Invitation email sent during onboarding; if unavailable, you can request that it be re-sent at https://cp.nordlayer.com/forgot-organization/.

If this does not work, please contact our support team at 888-245-0780.
Posted Dec 19, 2025 - 13:21 EST
This incident affected: Security Products (VPN).