System Performance & Connectivity

Incident Report for Rightworks Hosting

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 02, 2026 - 12:33 EDT

Investigating

We are currently experiencing higher than normal contact volume related to performance & connectivity of the Rightworks Hosted Desktop. Our engineers are working on identifying root cause and we will provide updates here as soon as they become available.
Posted Sep 02, 2026 - 11:06 EDT
This incident affects: QuickBooks Hosting (Hosted Desktop, QuickBooks).