Lacerte 2024 - Not Launching

Incident Report for Rightworks OneSpace

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 07:28 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 14, 2025 - 07:16 EDT

Investigating

We're currently investigating an issue where Lacerte 2024 is not launching for some users. We will provide updates here as they become available.
Posted Mar 14, 2025 - 06:55 EDT