QuickBooks Desktop - Unable to login to Intuit account/email

Incident Report for Rightworks Hosting

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 09:16 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2025 - 08:33 EDT

Identified

We are aware of an issue affecting some QuickBooks 2024 users. Customers may experience an indefinite loading screen when attempting to sign in to their Intuit account during the following actions:

Sending emails
Using QuickBooks Payments
Accessing Company > My Company

Intuit has acknowledged the issue. It is not specific to the Rightworks environment. For the latest updates, please visit https://status.quickbooks.intuit.com
Posted Jul 31, 2025 - 15:39 EDT